维护一个古老的系统,导航栏等地方的脚本在IE8及以上的版本中显示不正常,故只好维持低版本,但是系统内的新页面需要用到jQuery等东西,需要IE8以上的版本。而页面在IE内核浏览器中打开时,文档模式会被识别为“Quirks”导致新特性无法使用。所以网上找到了这篇文章(再谈IE的浏览器模式和文档模式)[……]

阅读全文